The WaterBoss 900 is a large capability water softener that works by eliminating dissolved calcium in your water as well as magnesium. Although the system requires little maintenance, you may still encounter a few problems. 

The common ones include:

E1 Error Code

Similar to most Waterboss softeners, the 900 may get “E1” message appearing on the systems digital display panel. The unit will start emitting a beeping sound. This error code is an indication that the unit’s controller is unable to locate the position of the home magnet disk.

Troubleshooting the “E1” code can be done by simply resetting the appliance. To do that, disconnect the transformer from the power source and let the unit rest for about half a minute seconds before re-plugging. 

If that doesn’t solve the Error Code, try making sure that the drive end cap four tabs of the system’s controller are securely seated.

Excess Water In The Brine Tank

If your brine tank has excess water, check if the brine line flow and air check could be clogged. In case they are, any obstruction should be removed and the brine cabinet cleaned. Also, check to ensure that the injector assembly has not become clogged for it may need cleaning or even replacing.

Also, check whether you need to lubricate the brine refill valve. If it’s malfunctioning or getting sticky, remove and lubricate using silicone grease before reinstalling.

No Soft Water

Check whether the brine cabinet has salt or if something is clogging it. Either add salt or remove whatever is causing the clogging. As well check whether a salt buildup or a salt bridge has formed in the unit’s brine cabinet. A blunt object can be used to dislodge or break the hardened salt.

Conclusion

Before you think of replacing the entire unit or even calling in the professionals for help, try the above easy troubleshooting techniques as they are likely to solve your Waterboss 900 problems and also remember to consult the product manual.